classic car forum header
Classic cars forum & vehicle restoration.
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
How To Register     Posting Photographs     Privacy Policy     F/book facebook.com/oldclassiccar

Engine overheating - causes?
Post new topic   Reply to topic    Classic cars forum & vehicle restoration. Forum Index -> Mechanical Restoration
Author Message
Invicta
Guest





PostPosted: Sat Mar 24, 2007 11:22 am    Post subject: Engine overheating - causes? Reply with quote

Any help relating to my 1975 Mitsubishi Series J26 SWB "Jeep" would be appreciated.

Now I've thoroughly cleaned out the water ways the engine continues to run hot.

Work done:
Rebuilt waterpump (bairings had worn out)
Rebuilt radiator (old, blocked and changed to larger core size to aid cooling)
Fitted new thermostat from manufacturer (former owner had not put one in)
No leaks occuing anywhere
Water is circulating well.

Associated (?)
I've noticed a former owner has filed the distributor clamp so that they could retard the timing further than standard.
I've spoken to them and they have confirmed they did this after changing the timing chain (engine is a 2.6 petrol Mitsubishi "Astron" as used in the Gallant range).

My assumption is the timing is too far advanced causing the combution to overheat the top end.
Any thoguhts on this please?

Incidentally can anyone recommend a good garage around the Tewkesbury area?
I need some welding to make a new frame fro the bench seat.

Kind regards, Bernard
Back to top
Rick
Site Admin


Joined: 27 Apr 2005
Posts: 21023
Location: North-west UK

PostPosted: Sat Mar 24, 2007 11:35 am    Post subject: Reply with quote

Must admit I was wondering about timing before reading your mention of the dizzy

Probably a silly question but the mechanical fan is on the right way around?

But timing does sound like the next thing to look into

R
_________________
Rick (OCC Admin)
Various 1920s-1960s - Austin, Morris, Commer, Dodge etc.
Back to top
View user's profile Send private message
Old-Nail
Guest





PostPosted: Sat Mar 24, 2007 6:12 pm    Post subject: Reply with quote

Have you used the manufacturers recommended coolant?

Some vehicles don't use water as a coolant but something that has a higher boiling point than water, Volkwagen are one such company.

I had a VW with exactly the same problem as you describe, I changed the radiator etc but it made no difference until I filled it with the recommended coolant rather than water and - Bingo!
Back to top
Invicta
Guest





PostPosted: Sun Mar 25, 2007 12:46 am    Post subject: Reply with quote

Rick & Old Nail,
I never would of thought of the fan - yes it's on the right way round.
Mitsubishi tell me the collant is correct type and mix.
My thanks to you both for the tips.
I'll let you know how I get on once the timing has been re-set.
Many thanks. Bernard
Back to top
UKdave2002
Guest





PostPosted: Sun Mar 25, 2007 10:14 am    Post subject: Reply with quote

Hi Bernard

Does the heater belt out hot air consistantly now ?, I think you said originally it blew cold even with a hot engine.

Checking the timing is essential, you are right its advanced timing that is normally assosiated with overheating.

Also is the radiator / expansion cap the correct presure ?

Daft question; but is the engine really overheating? I had a panic in the Stag once as the temp gauge went into the red, after checking everything the fault was the gauge's temp sender!! if your engine now has good circulation when originally it did not and this was the "original" cause of overheating, you may have "cooked" the temp sender ?

Dave
Back to top
Invicta
Guest





PostPosted: Sun Mar 25, 2007 4:03 pm    Post subject: Reply with quote

Dave,
By the way i always fancied a Stag but my long legs don't like the getting down and in\out of them - lovely cars though they are.

Good points raised:
Heater warms up with the engine (this was noticable after I put the thermostat in).
Cap is correct pressure.
Temp sender might have been fryed but the engine side of the thermostat housing does get very hot so I am presuming it's accurate.
(I have asked Mitsubishi to check this as part of the timing related service).

Unlike my petrol gauge which tells me the tank is half full when its empty -I know this as the tank is literally under the drivers seat so I give it a quick tap when I get in just to check how much fule is in there.

I am also reasonably sure that it's the timing as the 4x4 centre who carried out a basic pre delivery inspection before I bought it advised me that I should see how it went regarding the timing.
I presume that they detected the timing was out but as they didn't know much about the vehicle, or knew that there wasn't a thermostat fitted, they couldn't understand why there was no signs of overheating.

Once again thank you for your advice. If you are down near Tewkesbury get in touch and I'll pop the kettle on.

Incidentally, there are a few of the later J50 Series Mitsubishi "Jeeps" for sale on Japanese sites - from what I can gather these need the same amount of effort to unearth compatible parts.

Kind regards, Bernard
Back to top
Display posts from previous:   
Post new topic   Reply to topic    Classic cars forum & vehicle restoration. Forum Index -> Mechanical Restoration All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Forum T&C


php BB powered © php BB Grp.